Data View Module

Explore wave data and results in an interactive data visualization environment

 

Data View is a versatile data plotting and exploration tool for visualizing raw imported and processed data.  Features include 10 different page layout options with 1 to 6 plots per page and several different Plot Libraries to select from.  As your data analysis proceeds, the number of display options in Data View increases.  Image and movie-file export capability is included.

 

As described below, Data View features are accessible through a variety of interactive plot features, toolbar commands, and pull-down menu commands.

 

Data View Interactive Plot Features

Plot Menu – Right-Click on a plot title to access the menu for that axes.  All the available plots for the current data are available here as well as a variety of display options (described below).

Note: As data processing proceeds, additional plot options will become available.  See Plot Libraries for a list of available plots.

Record Scrolling – The scroll bar at the bottom of the Data View window allows the user to scroll forward and back through the data records.  A dashed vertical red line will appear in all time-series plot to identify the time of the currently active record.

Record List – Right clicking anywhere in Data View will bring up a menu of plot commands that includes “View Record List”.  This opens a Record List window that provides additional user controls for exploring data.  Specific controls for the Record List include:

 

Up Arrow: View Next Record

Right Arrow: Same as Up Arrow

Down Arrow: View Previous Record

Left Arrow: Same as Down Arrow

Page Up: View Next Record Section if Time Axis is Zoomed in

Page Down: View Previous Section if Time Axis is Zoomed in

Home: View First Record

End: View Last Record

Insert: Open Record List

Backspace: Close Record List

1 - 9 : Change Plot Layout to #1-9

0: Change Plot Layout to #10

 

View button – Time series plots zoom into display only selected records.

View All button – Time series plots display all records

 

Select Record Using Time Series Plot – See Time Axis Mouse Control in the Options pull-down menu below.

Rotate 3D Plots Using Mouse – Left Click the left or right side of a 3D plot to rotate clockwise or counter clockwise,  Shift + Left Click (or Right + Left Click) the top or bottom of a 3D plot to rotate up or down.

 

Data View Toolbar Commands

A toolbar across the top of the plot page has the following click-tools.  Simply click on each toolbar icon to activate the command.

 

 

Data View Toolbar Icons

 

Data View Pull-Down Menu Commands

File Menu – for loading and saving data, plots and movies

  • Load Raw Data – Select available data source to read and format unprocessed wave spectra files.
  • Open Processed File – Select and load processed data files from previous sessions.
  • Save As – Save current loaded data file with a new filename
  • Save – Save current data with existing filename
  • Splice Strom Events – Merge Oceanweather Storm events into current loaded data set. Storm events must be already processed and loaded as a second dataset using the Quick Compare feature.
  • Copy – Copy an image of the current window to the clipboard
  • Export – Save an image file, MATLAB figure file, movie file, or statistics file to disk
  • Page Setup, Print Preview, Print – Standard printing dialogue boxes
  • Clear All Data – Clear all currently loaded data and return to the splash screen.
  • Exit – Quit the program.

 

Module – Select module to launch

 

Settings

  • Parameters – Identify and save active parameter sets
  • Import – View Import Parameter for data currently loaded
  • Wave Systems – View Wave Systems Parameters for data currently loaded
  • Save Import Parameters for Current Data – Save Import Parameters for data currently loaded.
  • Save Wave Systems Parameters for Current Data – Save Wave Systems Parameters for processed data that is currently loaded.

Note: If the current parameters are already in the parameters database then they will save automatically. If parameters exist under the same name a prompt will appear to confirm to replace them.

 

  • Color Scheme – Set background and text colors for all windows and plots

 

Layout

  • Templates – Display Plot Layout Templates
  • Default Plots – Pre-defined plot layouts, including the following options:

      - Spectra Plots – Default layout for unprocessed data

         - Wave System Plots – Default layout for processed data

         - Climatology Spectra Plots – Default Climatology layout for unprocessed data

         - Climatology Wave System Plots – Default Climatology layout for processed data

         - Spectral Fit Plots – Default Spectral Fit plot layout for fit data

         - Sea State Plots – Default Sea State plot layout for Sea State data

         - Evaluate Plots – Default Evaluate plot layout for Evaluate data

 

Evaluate Plots

The Evaluate Plots can only be viewed when another data set is loaded using Quick Compare, analyzed using “Evaluate” from the Evaluate Module, or “Extract Spectral Fit Data” from the Options/Data Comparison menu.

 

Current Data is displayed using solid lines, and Comparison Data is displayed using dashed lines, in all applicable Evaluate Plots.

 

For the Quick Compare option, records from the comparison data will only be displayed if they fall within the Comparison Time Offset.  You can change the Offset by using the Options Menu or by right clicking on the Data Comparison info on the bottom right corner of the window. The data sets are time synchronized in the Evaluate option.

 

A blue line on time series plots indicates the record that is being viewed. This blue line will not appear if the data is outside the Comparison Time Offset.

 

The plots that are available depend on the data in each file.  The current data and the comparison data must both contain Wave Systems and wind information in order for those plots to be viewed.  See Plot Libraries for details.

The Input Data and the Wave System Data plots can also be selected for either the current or the comparison data.

 

• Saved Layouts- User-defined page layouts.  Save custom page layouts by name and recall them through this menu command.

 

Options

  • Time Axis Mouse Control – Toggles the ability to select records to display using the mouse on time series plots.  A vertical reference bar is displayed.
  • Plot Axis Scaling – Set 1D and 2D spectrum plots to logarithmic or linear Scale, this option also appears in the Plot Menu
  • Enable Pierson-Moskowitz – Toggles the display of a Pierson-Moskowitz (PM) model spectrum with the Frequency Spectrum (1D) plot.  The PM spectrum is computed from the wind speed for each record.
  • Enable 2D Contour Plot Legend – Toggle a colorbar plot scale for the 2D Contour Plot
  • Set Comparison Time Offset – When using Comparison Plots, this offset controls how far apart records can be compared.  Default is infinity.
  • Data Comparison – Default layout for processed data

         - Clear Data – Remove comparison data.

         - “Data Comparison Set Name” – Name of the currently loaded data used for Data Comparison

  • Load Friction Velocity – for importing friction velocity (ustar) from a Matlab data file.  Imported friction velocities are automatically interpolated in time to match the wave record time stamps. See Data Formats for file format requirements.

 

Help

  • About – Display Copyright and License information
  • Help Contents – Display Help Page

 

Module Toolbar Commands

In addition to the Module drop down menu, each module can be quickly accessed by clicking the corresponding toolbar icon.

 

 

 Module Toolbar Icons

 

 

Exporting Images

 

Exporting the plots shown in DataView is simple. From the File menu, select Export -> Image and select from one of the image file formats

 

The following image formats are available:

 

JPEG       JPEG image

PNG        Portable Network Graphics

FIG         Matlab FIG file

BMP        Windows bitmap

EMF        Enhanced metafile

TIF          TIFF image, compressed

EPS         EPS Level 3 Black and White

 

 

Changing the Image Resolution

The resolution can be changed in the Settings menu. Mouse over the Export Figure Resolution setting and choose between ‘Low’ and ‘High’.

 

Exporting Animations

It is also possible to create animations (AVI) from within DataView. From the File menu, choose Export -> Movie, and DataView will step through ALL of the records in the current file and export plots in the current DataView Layout. This can be memory extensive so it may be necessary to subset the processed file before creating the animation. Once the animation is complete a save dialog will appear. Choose a location to save the newly created AVI file.

 

** Make sure the DataView Window stays on top during the animation process because the animation image capturing is similar to a screen shot.

 

 

The Data View Module offers a variety of plot libraries to aid in the interpretation and analysis of user wave data. As data processing proceeds new plot types become available to the user. A summary of the various libraries and plot types available with each processing step appears below.

 

 

Input Data Plot Library

The basic wind and wave data plots for non-processed (Start Up) data sets appear in this library.

 

Information Plots

 

• Data Summary

 

Time Series Plots

 

• Wind Speed

• Wind Direction

• Wind Vectors

• Significant Wave Height

• Peak Period

• Mean Period

• Peak Direction

• Spectrograph

• Friction Velocity

 

Wave Spectrum Plots

 

• Frequency Spectrum (1D)

• Direction Spectrum (1D)

• Contour 2D Spectrum

• Polar 2D Spectrum

• Cartesian 2D Spectrum

 

 

Wave System Data Plot Library

These plots highlight the results of the wave partitioning analysis performed by the Wave Systems Module.

 

Information Plots

 

• System Summary

 

Time Series Plots

 

• System Wave Heights

• System Wave Periods

• System Wave Directions

• Wave Vector History

 

Wave Spectrum Plots

 

• Windsea Domain

• Windsea 1D

• Wave System 1D

• Wave System 2D

• Wave System Compass

• Wave System Contour

• Partition Segments

 

 

Climatology Plot Library

These plots show the climatology based on the entire data set. System (s) plots are only available for data processed with the Wave Systems Module.

 

Information Plots

 

• Climatology Table

• System Climatology Table (s)

 

Rose Plots

 

• Wind Rose

• Wave Height Rose

• Windsea Height Rose (s)

• Swell Height Rose (s)

 

Scatter Plots

 

• Height Period Scatter

• Period Direction Scatter

• Height Direction Scatter

• Height Period Direction Scatter

• System Height Period Scatter (s)

• System Period Direction Scatter (s)

• System Height Direction Scatter (s)

• System 3D Scatter (s)

 

Histogram Plots

 

• Wind Speed Histogram

• Wind Direction Histogram

• Wave Height Histogram

• Wave Period Histogram

• Wave Direction Histogram

• System Wave Height Histogram (s)

• System Wave Period Histogram (s)

• System Wave Direction Histogram (s)

 

 

Evaluate Plot Library

These plots are for comparing two data sets. System (s) plots are only available for data processed with Wave Systems Module. The Evaluate Time Series Residuals Plots, Evaluate Scatter Plots, Evaluate Contour Plots, and Evaluate Error Table are not available when processed by the Quick Compare method. See the Evaluate Module help for more details.

 

Information Comparison Plots

 

• Data Comparison

 

Time Series Comparison Plots

 

• Wind Speed

• Wind Direction

• Significant Wave Height

• Peak Period

• Mean Period

• Peak Direction

• Mean Direction

• System Height Comparison (s)

• System Period Comparison (s)

• Wave Height Bias

 

Wave Spectrum Comparison Plots

 

• Frequency Spectrum

• Direction Spectrum

• Windsea 1D Comparison (s)

• Wave System 1D Comparison (s)

 

Evaluate Time Series Residuals Plots

 

• Wind Speed

• Wind Direction

• Significant Wave Height

• Significant Wave Height (s)

• Peak Period

• Peak Period (s)

• Mean Period

• Mean Period (s)

• Peak Direction

• Peak Direction (s)

• Mean Direction

• Mean Direction (s)

 

Evaluate Scatter Plots

 

• Wind Speed

• Wind Direction

• Significant Wave Height

• Significant Wave Height (s)

• Peak Period

• Peak Period (s)

• Mean Period

• Mean Period (s)

• Peak Direction

• Peak Direction (s)

• Mean Direction

• Mean Direction (s)

 

Evaluate Contour Plots

 

• Wind Speed

• Wind Direction

• Significant Wave Height

• Peak Period

• Mean Period

• Peak Direction

• Mean Direction

 

Evaluate Error Table

 

• Wind Speed

• Wind Direction

• Significant Wave Height

• Peak Period

• Mean Period

• Peak Direction

• Mean Direction

 

Evaluate Quantile-Quantile Plots

 

• Wind Speed

• Significant Wave Height

 

 

Spectral Fit Plot Library

These plots are for comparing a data set with corresponding Spectral Fit results.

 

Spectral Fit Error Plots

 

• Composite Height Scatter

• System Height Scatter

• Composite Period Scatter

• System Period Scatter

• System Height Error Bar

• System Period Error Bar

• Fit Performance Table

 

Spectral Fit Spectrum Plots

 

• Composite 1D Fit

• Wave System 1D Fits

• Composite Directional Fit

• Wave System Directional Fits

• Composite Directional Distribution

• Observed Directional Distribution

 

Spectral Fit Series Plots

 

• Composite Height Series

• System Height Series

• Composite Period Series

• System Period Series

• Stacked Spectrum (Fit Tool only)

 

 

Sea State Plot Library

plots highlight the results of the sea history and extremal analysis performed by the Sea State Module

 

Peak Plots

 

• Wave Height PoT

• Wave Height Annual Maximum

• Wind Speed PoT

• Wind Speed Annual Maximum

 

Wave Height Recurrence Tables

 

• Generalized Pareto Distribution (GPD)

• Generalized Extreme Value (GEV)

• Gumbel

• Weibull

 

Wind Speed Recurrence Tables

 

• Generalized Pareto Distribution (GPD)

• Generalized Extreme Value (GEV)

• Gumbel

• Weibull

 

Wave Height Recurrence Plots

 

• Generalized Pareto Distribution (GPD)

• Generalized Extreme Value (GEV)

• Gumbel

• Weibull

• All (GEV, Gumbel, and Weibull)

 

Wind Speed Recurrence Plots

 

• Generalized Pareto Distribution (GPD)

• Generalized Extreme Value (GEV)

• Gumbel

• Weibull

• All (GEV, Gumbel, and Weibull)

 

Hs-Tp Scatter Plot

 

• Bulk

• Windsea

• Swell1

• Swell2